aboutsummaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 18 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0da0a8..5dc6fb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,29 @@
+# Maintainer: Unia <jthidskes@outlook.com>
+
pkgname=gstopwatch-git
-pkgbase=gstopwatch
-pkgver=2013.03.28
+_gitname=gstopwatch
+pkgver=2013.04.10
pkgrel=1
-pkgdesc="A simple stopwatch, written in GTK3."
-arch=(any)
+pkgdesc="A simple stopwatch, written in GTK3"
+arch=('i686' 'x86_64')
url="https://github.com/Unia/gstopwatch"
-license=(GPL)
+license=('GPL2')
depends=('gtk3')
+makedepends=('git')
+source=('git://github.com/Unia/gstopwatch.git')
+md5sums=('SKIP')
-_gitroot="https://github.com/Unia/$pkgbase"
-_gitname="$pkgbase"
-
-build() {
- cd "$srcdir"
- msg "Connecting to GIT server..."
-
- if [ -d ${_gitname} ] ; then
- cd ${_gitname}/
- git pull
- msg "The local files are updated."
- else
- git clone ${_gitroot} ${_gitname}
- cd ${_gitname}/
- fi
- msg "GIT checkout done or server timeout"
-
- make
+pkgver() {
+ cd $_gitname
+ git log -1 --format="%cd" --date=short | sed 's|-|.|g'
}
-pkgver() {
- cd "$srcdir/$_gitname"
- git log -1 --format="%cd" --date=short | sed 's\-\.\g'
+build() {
+ cd $_gitname
+ make
}
package() {
- cd "$srcdir/$pkgbase/"
-
- make DESTDIR="$pkgdir" install
+ cd $_gitname
+ make PREFIX=/usr DESTDIR="$pkgdir" install
}