aboutsummaryrefslogtreecommitdiff
path: root/fofi/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'fofi/CMakeLists.txt')
-rw-r--r--fofi/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/fofi/CMakeLists.txt b/fofi/CMakeLists.txt
new file mode 100644
index 0000000..fd61b25
--- /dev/null
+++ b/fofi/CMakeLists.txt
@@ -0,0 +1,28 @@
+#========================================================================
+#
+# fofi/CMakeLists.txt
+#
+# CMake script for the fofi library.
+#
+# Copyright 2015 Glyph & Cog, LLC
+#
+#========================================================================
+
+include_directories("${PROJECT_SOURCE_DIR}")
+include_directories("${PROJECT_BINARY_DIR}")
+include_directories("${PROJECT_SOURCE_DIR}/goo")
+
+add_library(fofi_objs OBJECT
+ FoFiBase.cc
+ FoFiEncodings.cc
+ FoFiIdentifier.cc
+ FoFiTrueType.cc
+ FoFiType1.cc
+ FoFiType1C.cc
+)
+set_property(TARGET fofi_objs
+ PROPERTY POSITION_INDEPENDENT_CODE True)
+
+add_library(fofi
+ $<TARGET_OBJECTS:fofi_objs>
+)