aboutsummaryrefslogtreecommitdiff
path: root/goo/CMakeLists.txt
diff options
context:
space:
mode:
authorCalvin Morrison <calvin@pobox.com>2023-04-05 14:13:39 -0400
committerCalvin Morrison <calvin@pobox.com>2023-04-05 14:13:39 -0400
commit835e373b3eeaabcd0621ed6798ab500f37982fae (patch)
treedfa16b0e2e1b4956b38f693220eac4e607802133 /goo/CMakeLists.txt
xpdf-no-select-disableHEADmaster
Diffstat (limited to 'goo/CMakeLists.txt')
-rw-r--r--goo/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/goo/CMakeLists.txt b/goo/CMakeLists.txt
new file mode 100644
index 0000000..f3f6932
--- /dev/null
+++ b/goo/CMakeLists.txt
@@ -0,0 +1,30 @@
+#========================================================================
+#
+# goo/CMakeLists.txt
+#
+# CMake script for the goo library.
+#
+# Copyright 2015 Glyph & Cog, LLC
+#
+#========================================================================
+
+include_directories("${PROJECT_SOURCE_DIR}")
+include_directories("${PROJECT_BINARY_DIR}")
+
+add_library(goo_objs OBJECT
+ FixedPoint.cc
+ GHash.cc
+ GList.cc
+ GString.cc
+ gfile.cc
+ gmem.cc
+ gmempp.cc
+ parseargs.c
+ Trace.cc
+)
+set_property(TARGET goo_objs
+ PROPERTY POSITION_INDEPENDENT_CODE True)
+
+add_library(goo
+ $<TARGET_OBJECTS:goo_objs>
+)